summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b2d05a..e40d7b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,10 +52,14 @@ else()
set(FUD_BOUNDS_CHECKING true)
endif()
+if(FUD_SAN)
+set(CVG_FLAGS ${CVG_FLAGS} -fsanitize=address -fsanitize=undefined -fno-sanitize=vptr)
+endif()
+
if (FUD_TEST)
add_subdirectory(test)
# set(CVG_FLAGS -fsanitize=address -fsanitize=undefined --coverage)
- set(CVG_FLAGS --coverage)
+ set(CVG_FLAGS ${CVG_FLAGS} --coverage)
target_compile_options(fud PUBLIC ${CVG_FLAGS})
target_link_options(fud PUBLIC ${CVG_FLAGS})
endif ()
@@ -102,6 +106,7 @@ set(FUD_HEADERS
"include/fud_c_file.hpp"
"include/fud_c_string.hpp"
"include/fud_directory.hpp"
+ "include/fud_drain.hpp"
"include/fud_file.hpp"
"include/fud_fixed_vector.hpp"
"include/fud_fud_type_traits.hpp"