summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2024-09-22 12:41:28 -0500
committerDominick Allen <djallen@librehumanitas.org>2024-09-22 12:41:28 -0500
commit7da829d48f9059c83ab9cada2c850621e8bbd3f3 (patch)
tree314e7a5b645e910d4997e3bee980bd2024f3087d /CMakeLists.txt
parentbf81e34921e3e30b05313efbcf5c9fa839cb7c05 (diff)
Basics of library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b135103..fc500ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,7 @@ endif()
project(libfud
VERSION 1.0.0
- DESCRIPTION "The Standard Library Extended and Exception Free"
+ DESCRIPTION "Library of FUD"
LANGUAGES CXX C)
set(CXX_CPPCHECK "project=build/compile_commands.json;enable=information;force")
@@ -15,10 +15,11 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS true)
add_library(libfud SHARED
source/libfud.cpp
- source/c_file.cpp
- source/string.cpp
- source/utf8.cpp
- source/utf8_iterator.cpp
+ source/fud_memory.cpp
+ source/fud_c_file.cpp
+ source/fud_string.cpp
+ source/fud_utf8.cpp
+ source/fud_utf8_iterator.cpp
)
target_compile_options(libfud PRIVATE ${FUD_WARNINGS})
@@ -35,7 +36,6 @@ set_target_properties(
if (FUD_TEST)
add_subdirectory(test)
-add_subdirectory(examples)
endif ()
if (FUD_DOC)