summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2024-10-02 11:42:00 -0500
committerDominick Allen <djallen@librehumanitas.org>2024-10-02 11:42:00 -0500
commit7eea7cd5e5b451de9db5bd289f8b5d152d5803f5 (patch)
treed4c948fc00f7c3c63fd9c6c8d85ac1c57c8241b5 /CMakeLists.txt
parent132ddf65fe6e253ebd113036d61c51cd0eb5e827 (diff)
Separate string view, implement string appending semantics.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d17a027..1f14216 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ add_library(fud SHARED
source/fud_assert.cpp
source/fud_memory.cpp
source/fud_c_file.cpp
+ source/fud_string_view.cpp
source/fud_string.cpp
source/fud_utf8.cpp
source/fud_utf8_iterator.cpp
@@ -93,6 +94,7 @@ set(FUD_HEADERS
"include/fud_result.hpp"
"include/fud_status.hpp"
"include/fud_string.hpp"
+ "include/fud_string_view.hpp"
"include/fud_unique_array.hpp"
"include/fud_utf8.hpp"
"include/fud_utf8_iterator.hpp"