summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2024-10-21 12:49:43 -0500
committerDominick Allen <djallen@librehumanitas.org>2024-10-21 12:49:43 -0500
commitb2dbcb55e2832c373fecb4033a3ed77e5dbc77aa (patch)
tree1f294fcf1d85a02db86de3eea2b03393fd89ca5a /CMakeLists.txt
parent6a27a2a4032e88fa9154ef0f0741edc584f7a701 (diff)
Add vector and option.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0e9aff..5a41872 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,12 +40,17 @@ target_link_libraries(fud ${SQLite3_LIBRARIES})
set_target_properties(
fud PROPERTIES
- CXX_STANDARD 23
+ CXX_STANDARD 20
C_STANDARD 23
CXX_EXTENSIONS OFF
C_EXTENSIONS OFF
CXX_STANDARD_REQUIRED ON)
+if (DEFINED FUD_BOUNDS_CHECKING)
+else()
+ set(FUD_BOUNDS_CHECKING true)
+endif()
+
if (FUD_TEST)
add_subdirectory(test)
# set(CVG_FLAGS -fsanitize=address -fsanitize=undefined --coverage)
@@ -98,6 +103,7 @@ set(FUD_HEADERS
"include/fud_directory.hpp"
"include/fud_fud_type_traits.hpp"
"include/fud_memory.hpp"
+ "include/fud_option.hpp"
"include/fud_permissions.hpp"
"include/fud_result.hpp"
"include/fud_span.hpp"
@@ -109,6 +115,7 @@ set(FUD_HEADERS
"include/fud_utf8.hpp"
"include/fud_utf8_iterator.hpp"
"include/fud_vector.hpp"
+ "${CMAKE_CURRENT_BINARY_DIR}/fud_config.hpp"
)
set_target_properties(fud PROPERTIES PUBLIC_HEADER "${FUD_HEADERS}")
@@ -121,5 +128,5 @@ install(TARGETS fud
include(cmake/CheckGit.cmake)
CheckGitSetup(GIT_HASH)
-configure_file(cmake/fud_version.hpp.in include/fud_version.hpp @ONLY)
+configure_file(cmake/fud_config.hpp.in include/fud_config.hpp @ONLY)
add_dependencies(fud AlwaysCheckGit)