summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2024-10-27 09:04:05 -0500
committerDominick Allen <djallen@librehumanitas.org>2024-10-27 09:04:05 -0500
commitb8345246dcc2121bcb6d1515a9341789de20199f (patch)
tree4a25857512a90ff38e8a40166c54694b74920216 /CMakeLists.txt
parentf84b8259f6e980fed647d8e1ec0634f89ee59c06 (diff)
First crack at file objects.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88833ab..1676173 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,14 +14,14 @@ set(CXX_CPPCHECK "project=build/compile_commands.json;enable=information;force")
set(CMAKE_EXPORT_COMPILE_COMMANDS true)
find_package(SQLite3 REQUIRED)
-
add_library(fud SHARED
source/libfud.cpp
source/fud_allocator.cpp
source/fud_assert.cpp
- source/fud_format.cpp
- source/fud_directory.cpp
source/fud_c_file.cpp
+ source/fud_directory.cpp
+ source/fud_file.cpp
+ source/fud_format.cpp
source/fud_memory.cpp
source/fud_sqlite.cpp
source/fud_string_view.cpp
@@ -102,6 +102,7 @@ set(FUD_HEADERS
"include/fud_c_file.hpp"
"include/fud_c_string.hpp"
"include/fud_directory.hpp"
+ "include/fud_file.hpp"
"include/fud_fixed_vector.hpp"
"include/fud_fud_type_traits.hpp"
"include/fud_memory.hpp"