summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2025-03-30 23:08:43 -0500
committerDominick Allen <djallen@librehumanitas.org>2025-03-30 23:08:43 -0500
commitcb9fa588ba8144fcdd52ba4b83d69d93fb18066f (patch)
tree214574ca68c1551ec76e7fbb9e0263793180231d /CMakeLists.txt
parent1d357adfa19725ee69fb267a363f1fd217b1272f (diff)
Add hash map.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 465e35d..7084262 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ add_library(fud SHARED
source/fud_directory.cpp
source/fud_file.cpp
source/fud_format.cpp
+ source/fud_hash.cpp
source/fud_memory.cpp
source/fud_print.cpp
source/fud_sqlite.cpp
@@ -112,8 +113,9 @@ set(FUD_HEADERS
"include/fud_drain.hpp"
"include/fud_file.hpp"
"include/fud_fixed_vector.hpp"
- "include/fud_type_traits.hpp"
"include/fud_format.hpp"
+ "include/fud_hash.hpp"
+ "include/fud_hash_map.hpp"
"include/fud_memory.hpp"
"include/fud_option.hpp"
"include/fud_permissions.hpp"
@@ -124,8 +126,10 @@ set(FUD_HEADERS
"include/fud_string.hpp"
"include/fud_string_convert.hpp"
"include/fud_string_view.hpp"
+ "include/fud_string_view_format.hpp"
"include/fud_sqlite.hpp"
"include/fud_text.hpp"
+ "include/fud_type_traits.hpp"
"include/fud_unique_array.hpp"
"include/fud_utf8.hpp"
"include/fud_utf8_iterator.hpp"