summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDominick Allen <djallen@librehumanitas.org>2024-10-03 09:28:01 -0500
committerDominick Allen <djallen@librehumanitas.org>2024-10-03 09:28:01 -0500
commitb50980ad70684530d55b7adf20de6047ebf53ba2 (patch)
tree576d284c732e2b5bfc7638a23d9bca4c86f5437c /test/CMakeLists.txt
parente420eca2b244c303af51534ab09632045a186b21 (diff)
Use a configure file for versioning including git revision.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 9061d55..19a5b98 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -36,6 +36,7 @@ function(fud_add_test test_name)
target_include_directories(${test_name} PUBLIC $<TARGET_PROPERTY:fud>)
target_link_libraries(${test_name} PUBLIC GTest::gtest_main fud)
+ target_include_directories(${test_name} PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/../include)
target_compile_options(${test_name} PRIVATE ${CVG_FLAGS})
target_link_options(${test_name} PRIVATE ${CVG_FLAGS})
@@ -51,6 +52,7 @@ function(fud_add_test test_name)
gtest_discover_tests(${test_name})
endfunction()
+fud_add_test(test_fud SOURCES test_fud.cpp)
fud_add_test(test_result SOURCES test_result.cpp)
fud_add_test(test_string SOURCES test_string.cpp)
fud_add_test(test_sqlite SOURCES test_sqlite.cpp)