summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 788e4ba..aef8052 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -13,12 +13,16 @@ endif()
set(gtest_URL https://github.com/google/googletest.git)
set(gtest_TAG v1.14.0)
+# Keep this setting above the FetchContent_Declare for googletest
+set(INSTALL_GTEST OFF CACHE BOOL "Enable installation of googletest.")
+
FetchContent_Declare(
googletest
GIT_REPOSITORY ${gtest_URL}
GIT_TAG ${gtest_TAG}
)
FetchContent_MakeAvailable(googletest)
+
include(GoogleTest)
enable_testing()
@@ -61,6 +65,7 @@ fud_add_test(test_allocator SOURCES test_allocator.cpp)
fud_add_test(test_assert SOURCES test_assert.cpp)
# fud_add_test(test_c_file SOURCES test_c_file.cpp)
fud_add_test(test_directory SOURCES test_directory.cpp)
+fud_add_test(test_file SOURCES test_file.cpp)
fud_add_test(test_format SOURCES test_format.cpp)
fud_add_test(test_option SOURCES test_option.cpp)
fud_add_test(test_result SOURCES test_result.cpp)